Start a new topic

Printer Error - FIRMWARE UNRESPONSIVE (PC - Printer connection lost / broken)

Hi All,

I have had some serious issues with my new Leapfrog Creatr HS (Dual Extruder, of course) because of connection issues.

My Interface & Software

I prefer to use the PC to Printer method of operation since it allows for greater control than printing from USB (which has also not worked well for me).

I use the supplied software, Simplify 3D, which I am quiet happy with; easy to use and has (for my/ my needs) a great deal of functionality.

My background:

A Production / Design Engineer since the late 1980's working with Production CNC machines and programming (originally writing code my own code and performing trig calcs by hand). The last 10-15yrs working in Automotive (with Polymers; PP & ABS for vehicle interior/exteriors) & Aerospace Design

The issue.

Using the supplied Leapfrog USB (1.8M cable) connecting my PC to the Creatr HS printer, I could never get this to work. I replaced this with a Belkin Premium 3M USB cable since my PC was not originally located next to my printer. However this work must better though I encountered this Firmware Unresponsive error showing up in the Communication tab in Simplify 3D software. The various steps to get the connection back involved shutting down the software and or the printer.

After logging a ticket on this I was informed that the cable must not be longer than the original 1.8M.

I was also told that I might need to use a Repeater USB type Cable. Checking on line for one with a Male USB (for the PC) and a Male USB-B (for the Printer) could not easily find one. I requested Leapfrog advise further on this but never received a response.

In the last 2 weeks since I received my printer i have attempted approximately making around 50-60 attempts to print with only 10 or so finishing the print cycle.

The ticket is still open regarding this issue.  The last test I performed per Leapfrogs instruction and do not recommend you do this unless instrusted was as follows:


   1. Remove the left panel from the printer.

   2. Disconnect the USB cable from the printer motherboard.

   3. Connect the original Leapfrog USB cable from my PC directly to the Printer motherboard 


   4. Change the Baud rate to 250000

Then to report back to Leapfrog how the prints turn out.

Not only did the PC not connect to the Printer using the original cable but would strangely not connect using my new Belkin cable.

Once I replaced the side panel, I plugged my USB cable in the rear of the printer and since have not been able to make a connection between PC and Printer.

Leapfrog have advised Tue, 10 Feb 2015 that the problem is with the motherboard and needs replacing.  A new board has been posted today.(I presume express) not a good start after 2 weeks.

Essentially I need to ensure that this printer can be successfully commissioned (to achieve quality / repeatability / reliability) as I intend to use this in conjunction with my business services as a Consultant Design Engineer (typically I work for large Automotive / Aerospace OEMs)/

Unfortunately this experience albeit brief so far has not given me much confidence that the printer is reliable enough to include it in my business services portfolio.

Hope this overview gives anyone with the same / similar issues some background detail that proves to be helpful.

I also look forward to hearing from others and their experience.

I do notice that there are others positing with less than positive results.

Kind regards,


Yeah I have an HS too ... So on mine I learned that you cannot make the "USB PC to 3D Printer Connection" until after the HS has fully booted up, trying to connect prematurely to the machine won't work. Also if you are using the front or rear USB port and want to switch from one to the other, you just need to turn the machine off connect to the other port and then turn the machine on. You cannot occupy both ports at the same time. If you are using a USB Flash Disk in the front and want to switch to computer controlled mode on the back then you have to turn the machine off remove the USB Flash Disk then connect the USB cable for Computer Control via Simplify 3D and turn on the printer, after the HS is fully booted then you can initiate your software connection. My friend was using my machine and he really just rushed through the process and concluded the thing was broke, then I showed him the procedure and all is well. I haven't had the issues sending my jobs from the computer to the HS over the USB cable at all and I am using the stock USB cable, but I have noticed that there are a lot of rough edges on the procedure of using the machine where people get tripped up... Leapfrog support is helpful in these situations at least they are for me and I work for them.


I've been having the same problem of having stalled prints mid-way to a 10+ hours print. The Firmware Unresponsive problem in Simplify3D is really annoying and I have been having this problem since I have received a new motherboard; the original has gone kaput somehow, and the replacement is behaving funny :(

Anyway, just a little note to anyone else who happens to meet this firmware unresponsive problem through Simplify3D on really long prints, I suggest the following procedure to salvage the print:

The aim is to reconnect the printer and resume printing from the point where the printer started to become unresponsive. This could only be done if the printer could be re-homed without the x-carriage hitting the half-printed object during re-homing.

  1. Go to Simplify 3D and record the Z location where the print failed. This could be done in 2 ways. 

    a) Go to 'Machine Control Panel' And read the Z-location on the Position Read out.

    b) If, for whatever reason you moved the Z-axis and could not do (a), you can read the layer where it stopped from the bottom left of the Live Preview Tracking page.
    Don't forget to check the tickbox for 'Live Preview Tracking' and Preview by 'Layer'. At the bottom left it should read 'Previewing File from line 1 to 0 - xxxx. Record the xxxx number as this is where your machine stopped. Multiply this number with the layer height to get Z height. (e.g layer 100 at 0.3mm layer height = 30mm)

  2. Disconnect and reconnect the usb plug, wait till Simplify3D reconnects to printer.

  3. Under Simplify3D, exit preview mode to generate a modified g-code

  4. Under 'Edit Process Settings', change the following:
    a) Under the 'Advanced tab - check "Start printing at height" and input the z-height where your print had stopped
    b) Under 'Additions' Tab - un-check the 'Include skirt or brim' tickbox

  5. Generate the modified G-code and run it. 

  6. Open Manual Control and be ready for the emergency stop button in case anything goes wrong (X-carriage hitting half-printed objects etc.)

The modified g-code could re-start your print at the LAYER where you stopped, so there would be some overlap. Depending on your object, this overlap may or may not be very visible. But I hope this could help salvage whatever print you have. 

You could probably edit the modified G-code on a text editor and figure out the exact g-code line where you left off, and delete the unnecessary codes. (From step 1b. but change the Preview by Layer to Preview by Line and read where the Line stopped. Then, compare original g-code to modified g-code and so on and so forth).
I think it's too much work and I'll live with some small artifacts that I could later sand down instead. 

This method could be extended to cloggings mid-print. But you'll need a caliper to guesstimate the z-height where the print stopped (Google 'vernier caliper measure depth' to see how to do it). And plug the z-height to step 4a. 

Meanwhile, I am still on the lookout for a permanent fix to this issue. I will try a shorter USB cable and pray that no more Firmware Unresponsive problem will occur. 

Wishing you all the best,

Joe Dion Trisnadi

Hi Joe,

Are you still having the same error; Firmware Unresponsive?

Also I wonder which printer you have, I myself have a Creatr HS all be it, it is my second printer since the first one just basically would not work and after nearly 2 months of continuous emailing to the Tech Support folk they could not fix it and ultimately replaced it.

Fantastic you would think but if todays performance is anything to judge it by you would be wrong.

So I'm interested to hear the experiences of other users that might be using the same 'generation' printer as myself; happy to hear more about experiences - good or bad..

Really like to hear any other interesting / general observations also.

Thanks in advance and look forward to comments and thoughts.

Kind regards


I'm using Creatr Dual Extruder (not HS). So far I have recently installed a UPS and used a shorter USB cable. I plug both my printer and PC to the same UPS. This is based on an advice given in my ticket to the support team: 

"Concerning the other question, an upgrade to a shielded shorted USB cable could be the solution. Also having the PC and the Printer on the same grounded outlet(to have common ground) can be very useful. Also make sure that there are no other big electronic machines on the same power group(like microwave / oven / water heater / Electrical Central heating etc.). Also PSU / other power cables should not run next to the Serial USB communication cable." -Pim R. | Leapfrog Research and Development

So far I haven't had that Firmware Unresponsive issue. But most of my prints currently lasts around 5 hours. I have yet to run 10+ hours prints. Only time will tell if these solutions fixed the issue.

Best Regards,

Joe Trisnadi

Hi All,

I am just wondering how many others are in / have had this experience with connectivity as I.

I have received a replacement printer 2-3 months ago and have been patiently trialling and testing it only to still find that I get connectivity errors.

Earlier this year after receiving my first Creatr HS only for it to result in a mamoth 45-50 page long session between me and Leapfrog Technical Support to try and resolve this issue about connectivity never found a solution. The solution was to send me a new printer which I can now attest to sadly does not still work as it is intended.

Despite it have a USB port for standalone operation does not exclude the fact that there are issues occurring when running it in what I call normal operation, meaning from the PC via using a USB cable as I must have this to be able to calibrate and recheck the continually changing bed / nozzle gap.

Have any of you faced the same issues and what solutions have you found by the community or been offered by Leapfrog?

I would be grateful to here back to understand this problem as after 6months I am still not able to utilise the printer in a consistent manner with any real sense of reliability.

Kind regards,


1 person likes this

Hey David,

I am having the same issue, I think. 

I also don´t get connected with the Creatr HS though I followed exactly the steps given in the IFU. 

Background: I tried to print from USB stick which actually didn´t work out well: The extruder pulls the printed object from the bed and destroys it...I think the bed isn´t calibrated correctly and so I tried to connect the Creatr HS with the computer to calibrate the Creatr HS.

For now, I don´t have any clue how to fix this problem. I haven´t opened a ticket at the Leapfrog Service, yet, because I hope I might get some helpful hints here.

I would be grateful for any kind of help due to the fact that I can´t print as long as this problem isn´t solved....

best regards


Dear Birger,

Regarding the issues you are having with the calibration of the bed and the connection issue as well I would ask you if you have the latest software and firmware version for the HS printer:

Update CreatrHS Stand-Alone software

Flash new firmware on the CreatrHS

Set extruder offset for your CreatrHS (M50)

Please make sure to install the updates in the order of the links:

- first the software;

- then the firmware.

Login or Signup to post a comment

User Manual

Quick Start Guide

Installation clips
The following 3 clips will guide you through the installation process of your CreatrXL. By following these, you will be printing within 30 minutes. First start with unpacking the printer. Clickhere to see how you correctly pick up the printer

Part 1 of 3: Unpacking your CreatrXL

In this clip, you will be guided through the unpacking of a brand new CreatrXL. The unboxing along with the location of tie wraps which need to be removed are shown, as well as the process of a connecting the cables to the printer and computer.

Part 2 of 3: Software and configuration

In this clip, we will show you how to install the required software. The first step is to download and install the Arduino software to make it possible for your computer to connect with the printer. The next step is to download and install the Repetier Host Leapfrog software or that controlls your 3D printer. We have tried to make this as simple as possible and also provided direct downloading links per operating system.

If you are using the new Simplify 3D software you can follow all the steps except for the Repetier-Host Leapfrog installation and using explanation. Simply download the software via the purchase link and before first use a pop-up will appear showing you the Simplify 3D Quick start guide. You can also download the Quick start guide or access it from the software via help –> Quick start guide. The quick start guide will briefly explain the functions of the software so that you can start your first print.

Please select you operating system and follow the descriptions in the movie.

Operating systemWindows

The first step is to download and install the Arduino software to make it possible for your computer to connect with the printer. The next step is to download and install the newest version of the Repetier Host Leapfrog software as shown in the clip. This software allows you to convert your 3D software file [STL for example] to a printable file [G-Code] and allows you to control your printer. The Repetier Host Leapfrog software contains standard CreatrXL Print Profiles. Just select the extruder, the filament material as well as the color and Repetier will automatically select the ideal print temperature providing you the best print quality possible. There is also a Leapfrog support button implemented in the software. A Mac version will be available soon.

If you have followed the installation procedure, but you can’t control your Leapfrog CreatrXL and the “6 commands waiting” message in Repetier-Host Leapfrog won’t disappear, you have to install the 2.8.28 drivers. Please see Solution can’t connect 6 commands waiting in Repetier-Host Leapfrog how to do so.

For a more thorough description of Slic3s settings please check this guide!

Windows 8
To install the Arduino drivers on a computer with Windows 8 follow these steps after downloading the Arduino software.

- Save unsaved work and write the instructions down
[your computer will reboot into startup options screen]
- Press the Windows Key and the ‘R’ key simultaneously
- Copy the command inside the brackets
–>[ shutdown.exe /r /o /f /t 00 ] – Select ‘Troubleshoot’
- Select ‘Advanced options’
- Select ‘Startup Settings’
- Select ‘Disable Driver Signature Enforcement’
- Install driver as usual via device manager


In this clip, we will explain you how you can generate a STL file using Sketchup. We show you what to download and how to export your design in STL.

Part 3 of 3: Making your first print!

In this final clip, the process of creating your first print will be explained. This starts with removing the callibration print that is already on the print bed. How to insert the filament and operate the Repetier Host Leapfrog software is also shown, which should culminate in your first 3D Print on the CreatrXL!

Google sketchupHow to export STL files from Sketchup

The first step is to download and install the Arduino software to make it possible for your computer to connect with the printer. You will then need to in stall this driver for OSX to recognize the hardware.

The next step is to download the Repetier software as shown in the clip. This software allows you to convert your 3D software file [STL for example] to a printable file [G-Code] and allows you to control your printer. We have developed standard print profiles for the CreatrXL. Please follow the instructions below to install the print profiles for Mac [not yet included in the video]:

- Download This file
- Go to your Home Folder on Mac and select “Go to Folder” from the Go Menu en type “Library/Application Support/Slic3r/” - Unzip the file you just downloaded and dump the contents in the Slic3r folder, it will replace your existing settings. If you want to keep your current settings as well, take the contents from each folder and put this in the same folder in the Home/Libaray/App../Slic3r folder.

Download instructions by Deepak Dinesh Mehta For a more thorough description of Slic3s settings please check this guide!

Troubleshooting Trees

Filament Guide

  • Extrude at ~ 225o C.
  • Requires heated bed.
  • Works reasonably well without cooling.
  • Adheres best to polyimide tape.
  • Filament tolerances are usually tighter.
  • Prone to cracking, delamination, and wraping.
  • More flexible.
  • Can be bonded using adhesives or solvents(Acetone or MEK).
  • Fumes are unpleasent in enclosed areas.
  • Oil Based.
  • Extrude at ~ 180-225o C.
  • Benefits from heated bed.
  • Benefits greatly from cooling while printing.
  • Adheres well to a variety of surfaces.
  • Finer feature detail possible on a well calibrated machine.
  • Prone to curling of corners and overhangs.
  • More brittle.
  • Can be bonded using adhesives.
  • More pleasant smell when extruded.
  • Plant Based.

Demo Print Downloads

Drivers Downloads

Software Downloads

Firmware Downloads

Please request a firmware download via the Ticket System

Creatr XL Video Library